Hey blogger, ketemu lagi nih. Udah lama rasanya ga nongol di blog ini, soalnya lagi banyak kerjaan, jadi ga sempet nulis deh :(

Kali ini, saya mau membahas tentang routing protocol, lebih tepatnya OSPF. Apa sih OSPF itu ? OSPF kepanjangan dari Open Shortest Path First, yang salah satu keunggulannya, semua device dapat berkomunikasi dengan protokol ini. Tidak hanya merk CISCO saja.

Alasan untuk mengkonfigurasi OSPF dalam sebuah topologi adalah untuk mengurangi overhead (waktu pemrosesan) routing, mempercepat convergance, serta membatasi ketidakstabilan network disebuah area dalam suatu network.

Semua paket OSPF mempunyai 24 byte yang berisikan informasi yang diperlukan. Packet header ini terdiri dari berbagai bidang seperti jenis-jenis paket OSPF, router ID serta alamat IP dari router yang mengirimkan paket.

Yuk kita mulai ke konfigurasi ……………………..
topologi+ospf+cisco

Bentuk topologi OSPF ini masih sederhana, dimana terdapat 3 buah router, 3 buah switch dan 5 buah komputer. Konfigurasi ini diperuntukkan untuk single area OSPF. Area ini saya tulis sebagai ospf 1.

Konfigurasi untuk Router Lab_A seperti ini :

hostname Lab_A
!
!
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface Loopback0
ip address 172.16.10.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 192.168.20.1 255.255.255.0
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 192.168.10.1 0.0.0.0 area 0
network 192.168.20.1 0.0.0.0 area 0
!
ip classless
!
!
!
!
!
!
!
line con 0
password cisco
login
!
line aux 0
!
line vty 0 4
password cisco
login
!
!
!
end

Untuk Router Lab_B

hostname Lab_B
!
!
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface Loopback0
ip address 172.16.20.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.30.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 192.168.20.2 255.255.255.0
clock rate 64000
!
interface Serial0/0/1
ip address 192.168.40.1 255.255.255.0
clock rate 64000
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
!
!
!
!
!
!
!
line con 0
password cisco
login
!
line aux 0
!
line vty 0 4
password cisco
login
!
!
!
end

Untuk Router Lab_C

hostname Lab_C
!
!
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface Loopback0
ip address 172.16.30.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.50.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 192.168.40.2 255.255.255.0
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 192.168.40.0 0.0.0.255 area 0
network 192.168.0.0 0.0.0.255 area 0
network 192.168.50.0 0.0.0.255 area 0
!
ip classless
!
!
!
!
!
!
!
line con 0
password cisco
login
!
line aux 0
!
line vty 0 4
password cisco
login
!
!
!
end